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What Is
Squiggle?

Introducing Squiggle

Introducing Squiggle

Thank you for choosing Squiggle 5!

Squiggle 5 is the answer to frequent complaints about the dry
nature of computer line drawings. With Squiggle 5, you can make
your graphics more spontaneous and just plain fun. Clients will
immediately see that your ideas are exciting.

Squiggle 5 is perfect for anyone who uses CAD programs to
produce their designs; for example:

e Building and landscape architects.

e Urban planners.

e Ad designers.

e Interior designers.

e Theatrical set designers.

e Furniture manufacturers.

e Mechanical and industrial designers.

e Technical illustrators.

e Artists and other creative professionals.

e Home hobbyists.

Modern illustration tools and imaging technology provide a level of
detail and precision that more traditional methods cannot match.
Ironically, this very level of precision can impart a cold,

“machine-generated” character to a designer’s work that a client
may find off-putting.

1-1
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Figure 1-1. Typical CAD Drawing -- Before Squiggling

When you use an ink pen on a piece of paper, the strokes are
thicker where the grain absorbs more ink, corners don’t quite meet
or cross, straight lines aren’t quite straight and so on.

How Does Squiggle 5 takes the lines in your drawings and applies random

Squiggle Work? changes to them -- in a fraction of the time it would take to achieve
this effect with a pen! Each line comes out slightly different so the
results are not predictable. After all, neither is the human hand.

Figure 1-2. Typical CAD Drawing -- After Squiggling

1-2 Introducing Squiggle
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Features

Introducing Squiggle

Squiggle 5 boasts many new features and performance
enhancements, including:

Increased drawing support: Except for the Squiggle
algorithms themselves, Squiggle 5 has been completely
rewritten. Squiggle 5 supports both DWG and DXF files created
with all versions of AutoCAD® from Release 2.5 onward.

Improved exporting capabilities: In addition to the BMP, GIF,
TIFF and JPEG formats previously supported, Squiggle 5 adds
support for Portable Network Graphics (PNG), the AutoCAD
Drawing Web Format (DWF), and the increasingly-popular
Scalable Vector Graphics (SVG) format. New exportable features
include a user defined image size (in pixels), selectable number
of colors (bits per pixel) and the ability to export GIF or PNG
images with a transparent background.

Squiggle style settings based on pens or layers: Squiggle 5
offers greater control over the results by enabling you to apply
Squiggle styles to layers as well as to pen types (as in previous
versions). If you have a drawing with two or more layers that
use the same pen, you can Squiggle each layer independently to
contrast them.

Ability to save squiggled drawings back into DWG or DXF
formats: Not only can you convert your DWG files to DXF and
vice versa, but now you can save your squiggled drawing back to
a DWG or DXF for use with your main CAD application.

Custom Squiggle styles stored as small files: Easily move
your custom Squiggle styles from one machine to another.
Custom Squiggle styles are now saved as small individual files.
This allows co-workers or others to quickly import your custom
made styles.

Custom Pen Templates stored as small files: Easily move
your custom pen templates from one machine to another.
Custom pen templates are now saved as small individual files.
This allows co-workers or others to quickly import your custom
made pen templates.

Improved handling of HPGL and HPGL/ 2 plot files:
Squiggle 5 offers greatly improved support for plot files in both
HPGL and HPGL/2 formats.

A more consistent user interface: We have streamlined the
user interface of Squiggle 5 so that you can find the features you
need more quickly and easily.

1-3
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System
Requirements

1-4

Squiggled entity selection: With Squiggle 5, you can turn
squiggling on or off for supported entity types (LINE, CIRCLE,
ELLIPSE, ARC, POLYLINE, LWPOLYLINE and BLOCK/XREF).

Insight Plot Style Tables: Insight Plot Style Tables let you
override the pen properties defined in your drawing file before
sending it to a plotter. For example, you can create an Insight
Plot Style Table that uses custom lineweights not defined in the
drawing file.

Squiggle 5 requires the following minimum system configuration:

Windows 9x/ME/NT/2000/XP

A 450-MHz or faster processor

128 MB RAM

20 MB disk space

Pointing device (mouse, tablet etc.)

A Windows-compatible printer or plotter

Less capable machines can run Squiggle 5, but the results may be
less than ideal. Sufficient swap space is also required to handle any
data or drawing files saved. Additional memory and/or a faster
processor will directly improve performance and capacity.

Introducing Squiggle
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Getting Started with
Squiggle 5

This section guides you through the Squiggle 5 installation process
and includes a brief “quick-start” procedure to help you familiarize
yourself with the program.

Installing To install Squiggle 5:

Squiggle 5 1 Download Version: Locate the file you downloaded
(Squiggle5Setup.exe) and double-click on its icon to launch
the setup program. Continue with Step 3;

-OR -

CD-ROM Version: Insert the application CD-ROM into your CD
drive. If your system is configured to auto-run CD-ROM discs,
the Squiggle 5 setup program will launch automatically.
Continue with Step 3.

2 Locate the file named Autorun.exe on the Squiggle 5 CD and
double-click on its icon to launch the setup program.

3 Click the Install Squiggle button.

Getting Started with Squiggle 5 2-1
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2-2

4

When the setup program Welcome Screen appears, click Next.

i% Insight Development Squiggle 5 Setup =] x|

7! Welcome to the Insight

Development Squiggle 5
( Installation Wizard

Itiz strongly recommended that you exit all Windows programs
befare running this setup program.

Click Cancel to quit the setup program, then close any programs
you have running,  Click. Mest to continue the installation.

WARMIMNG: This program iz protected by coppright law and
international treaties.

Unauthorized reproduction or distribution of this program, or any
portion of it, may result in severe civil and criminal penalties, and
will be prozecuted to the mazimum extent pozzible under law.

< Back Cancel |

Figure 2-1. Squiggle 5 Setup Program - Welcome Screen

5

10
11

Read the Squiggle 5 license agreement and indicate your
acceptance of its terms by clicking the top radio button.

Click Next.

Review the Squiggle 5 ReadMe file for up-to-date information
about the specific version of Squiggle you are installing. Then,
click Next.

Personalize your copy of Squiggle 5 by entering your full name
and organization name.

Select a destination folder for Squiggle 5, or use the default
destination (C:\Program Files\Insight Development\Squiggle\).

Click Next twice.

When the setup program finishes copying the program files to
your system, click Finish.

Getting Started with Squiggle 5
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Activating If you have access to the Internet, the easiest way to register and

Squiggle 5 activate your copy of Squiggle 5 is by using our online registration
form. Otherwise, you can call Insight Development Technical
Support to obtain an Unlock Code that will allow you to activate the
product.

You can also transfer your Squiggle 5 license to another machine.
Refer to Transferring A Licensed Copy of Squiggle 5 To Another
Machine for instructions.

Online Activation

To activate your copy of Squiggle 5 via the Internet:
1 Connect to the Internet, if you aren’t already connected.

2 Launch Squiggle 5 by double-clicking the shortcut placed on
your desktop during installation. Or, from the Start Menu, select
Programs -> Insight Development -> Squiggle ->
Squiggle 5.

3 When the Register Screen appears, make a note of the serial
number displayed in the upper-right corner of the screen.

Register Screen E

Insight ‘STATUS: Evaluation < SERIAL #: 87310367 *
Development

o "
S{@U IGGLE"S D aps Left Before Meeding Activation: 0 Days

insight
|/ ;
" Update License
) Transten Licerse
Activate | hloek | Lontinue |

Figure 2-2. Squiggle 5 Register Screen

4 Click the Activate button.

5 Fill out the online registration form and click the Submit button.

Getting Started with Squiggle 5 2-3
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6

7

When your registration information has been submitted
successfully, you will see a confirmation message, along with
instructions for completing the activation process. Follow the
instructions on this page, then click the Close button.

Click Continue to begin using Squiggle 5!

Offline Activation

To activate your copy of Squiggle 5 offline:

1

Launch Squiggle 5 by double-clicking the shortcut placed on
your desktop during installation. Or, from the Start Menu, select
Programs -> Insight Development -> Squiggle ->
Squiggle 5.

When the Register Screen (Figure 2-2) appears, make a note
of the serial number displayed in the upper-right corner of the
screen.

Call Insight Development at +925.244.2000 to obtain an Unlock
Code. (You will be asked for your serial number.)

Enter the Unlock Code in the box provided.
Click the Register License radio button.
Click the Unlock button to begin using Squiggle 5!

Transferring A Licensed Copy of Squiggle 5 To Another
Machine

To transfer your licensed copy of Squiggle 5 to another machine:

1

(o) IO B SN OV

2-4

Launch Squiggle 5 by double-clicking the shortcut placed on
your desktop during installation. Or, from the Start Menu, select
Programs -> Insight Development -> Squiggle ->
Squiggle 5.

Press and hold down the <Shift> key to display the Register
Screen (Figure 2-2).

Click the Transfer License radio button.
Enter the current serial number in the box provided.
Click the Transfer button.

An alert appears, displaying a new, unique Unlock Code. Make
a note of the new Unlock Code and click OK.

Getting Started with Squiggle 5
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7 Make a note of the new serial number associated with the new

Unlock Code.

8 Click the close ("*X”) button in the upper-right corner of the
Register Screen, or the Continue button.

You can now install this copy of Squiggle 5 on another machine,
using the new Unlock Code.

Quick Start This section introduces you to Squiggle 5 by guiding you through

some simple Squiggle operations.
1 From the File menu, select Open...

Open 2] =]
Laak in: I 3 Samples j gl
Entities.dwg Teut.plt Previe
ouze, dwg Wictorianz. dwg
Housze.plt il dweg
Mozzle.plt
Preview.dwg
TestPattern.dwg
File name: IHouse.dwg DOpen I

Files of type: ISquiggIe Files =l Cancel |

Figure 2-3. Squiggle 5 File Open Dialog

2 Select the sample file named “House.dwg” and click Open.
3 Do any of the following:

e Press F5 on your keyboard;

e Click the Squiggle icon (@) in the Toolbar;

[Took Window Hebp e Select Squiggle... from the Tools menu;
Sl e Right-click on the drawing window and select Squiggle...

Eesquigaler BE

Unsauiagle F7 from the pop-up menu.

Options...  F10

Getting Started with Squiggle 5
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H Squiggle - [House. dwg] M |
Fie Edit Wiew Fomat Tools Window Help 18] x|
ZHE M| 8 a® s = al||tdsl Space e 7|

Squiggle...
Fesguiagle R

rsquiagle £
Zoom Window

Zoom Extents
Pan

Save Az
Export
Expuort Preview.

Flot... Cirl+F

Drawing Properties...

H I —
i I —
= | I
Squiggle the cument drawing A

Figure 2-4. The Squiggle Right-Click Menu

Check the Select All box.

5 Right-click anywhere in the Style column and select the “Shaky”
style.

Squiggle x|

1 v Mone
Dashed
Fuzzy

Mapkin

Sketch
Steady
¥ Select Al Wavy

EasetAIIl ok | Cancel | Help |

Figure 2-5. Applying the “Shaky"” Style to All Pens

2-6 Getting Started with Squiggle 5
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6 Click OK to see the effect of this style on the drawing.

Figure 2-6. Sample Drawing After “"Shaky” Squiggling

7 If you like the overall effect of this style but want to see a
variation:

e Press F6 on your keyboard;
e Select Resquiggle from the Tools menu;

e Right-click on the drawing window and select Resquiggle
from the pop-up menu.

8 To try a different style, repeat Steps 3 through 6 and select
another style.

9 Once you are satisfied with the results, your Squiggle output is
ready to use. You can send it to a printer or plotter, save the
image as a squiggled DWG or DXF file or export the image in
one of several popular file formats.

Congratulations! You have just squiggled your first project. To
explore the powerful capabilities of Squiggle 5 in greater depth,
continue with the next section.

Getting Started with Squiggle 5 2-7
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Uninstalling
Squiggle 5

2-8

Should you need to remove Squiggle 5 from your system for any
reason:

1
2
3

From the Start Menu, select Settings -> Control Panel.
Double-click on Add/Remove Programs.

In the list of installed programs, scroll downward until “Insight
Development Squiggle 5” is visible.

Click on “Insight Development Squiggle 5” to select it, then click
Add/Remove....

Getting Started with Squiggle 5



Squiggle 5 User’s Manual

Squiggling A
Drawing

Squiggle Basics

Squiggle Basics

Select Squiggle... from the Tools menu to apply a Squiggle style to
one or more pens (or layers) in your drawing. To choose a Squiggle
method (by pens or by layers), select Options... from the Tools
menu and click on the Squiggle tab.

Squiggling by Layers

If you have chosen Squiggle by Layers in the program options
dialog, the Squiggle dialog looks like this:

ETDOY |

| Layer | Color | Lingweight | Style |

a M Elack Default Mone

LAY000 a5t Default Mone

LaY001 W Red Default Mone

LaY00z2 O vellow Default Mone

LAYO03 EGreen Default Mone

LAYO04 O Cyan Default Mane

LAYO0S MEle Default Mone

LAYO0E W Magenta Default Mone

LAYOO7 M Elack Default Mone

LAYO0S [mE Default Mone

LaYooe 09 Default Mone

LaY010 W10 Default Mone

LaYO11 O Default Mone

LaYo1z Wiz Default Mone

LAYO13 W13 Default Mone

LAYO14 W14 Default Mone

I Select Al

Reset Al | ok | Cancel | Hel

Figure 3-1. Squiggle By Layers Dialog

3-1
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/_\ Tip

3-2

To Squiggle one or more layers:

1 Click on a layer name to select it. To select multiple layers, hold
down the <Ctrl> or <Shift> key and click. To select all layers,
check the Select All box.

For each layer you wish to Squiggle, you can substitute a
different color and/or lineweight for the output than that defined
in the drawing for that layer.

If you plan to use different colors, lineweights and/or styles on
each Squiggled layer, select one layer at a time, make your
choices and repeat as needed for the other layers.

Click on the Color column to select a new color for a layer.

Click on the Lineweight column to select a new lineweight for a
layer.

4 Click on the Style column to select a Squiggle style for a layer.
To edit the Squiggle settings of a layer, left-click to bring up a
dialog box, or right-click to bring up a pop-up menu.

To edit the Squiggle settings of multiple layers, hold down the
<Shift> key and left-click to bring up a dialog box, or right-click to
bring up a pop-up menu. This will apply your choice to all selected
layers.

When you are finished, click OK to Squiggle your drawing.

Squiggle Basics
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Squiggle Basics

Squiggling by Pens

If you have chosen Squiggle by Pens in the program options dialog,
the Squiggle dialog looks like this:

ET———CY

Fen | Color | Lineweight | Style |

1 W Red 0.25 mm [

2 O vellow —0.25mm Mone

3 Eareen —0.25mm Mone

4 OCyan ——0.25mm Mone

5 M Elue —0.25mm Mone

[} W Magenta —0.25 mm Mone

7 M Elack —0.25mm Mone

g (B —0.25mm Mone

I~ Select &l
Reset &l | ok | Cancel | Hel

Figure 3-2. Squiggle By Pens Dialog

To Squiggle one or more pens:

1 Click on a pen number to select it. To select multiple pens, hold
down the <Ctrl> or <Shift> key and click. To select all pens,
check the Select All box.

For each pen you wish to Squiggle, you can substitute a
different color and/or lineweight for the output than that defined
in the drawing for that pen.

If you plan to use different colors, lineweights and/or styles on
each Squiggled pen, select one pen at a time, make your
choices and repeat as needed for the other pens.

Click on the Color column to select a new color for a pen.

Click on the Lineweight column to select a new lineweight for a
pen.
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4 Click on the Style column to select a Squiggle style for a pen.

Ti To edit the Squiggle settings of a pen, left-click to bring up a dialog
f E Ip box, or right-click to bring up a pop-up menu.

To edit the Squiggle settings of multiple pens, hold down the
<Shift> key and left-click to bring up a dialog box, or right-click to
bring up a pop-up menu. This will apply your choice to all selected
pens.

When you are finished, click OK to Squiggle your drawing.

Resquiggle/Unsquiggle
If you are generally satisfied with your Squiggled output, but want
to see a variation on the style(s) you have chosen:

e Press F6 on your keyboard;

e Select Resquiggle from the Tools menu;

¢ Right-click on the drawing window and select Resquiggle

from the pop-up menu.

To restore a drawing to its pre-squiggled state, do one of the
following:

e Press F7 on your keyboard;

e Select Unsquiggle from the Tools menu;

¢ Right-click on the drawing window and select Unsquiggle
from the pop-up menu.
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Style

Select Style... from the Format menu to create, edit or import
Squiggle styles.

Squiggle 5 provides seven preset Squiggle styles:

e Dashed

o Fuzzy

¢ Napkin

e Shaky

e Sketch

e Steady

e Wavy

You can apply one of these, create custom styles yourself or import
styles created by other Squiggle 5 users.

Each Squiggle 5 style consists of a series of actions.

Dashed: The Dashed style looks like a fragmented, wiggled line.
The style is comprised of three Squiggle actions:

Slide - 10, 0
Sputter - 20, 10
Wiggle - 50, 17

Figure 3-3. The “"Dashed” Squiggle Style
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Fuzzy: The Fuzzy style is an abstract multiple stroke line. The style
is comprised of three Squiggle actions:

Sputter - 20, 10
Wiggle - 3, 40
Slide - 80, 0

it

o viranr, o

Figure 3-4. The “"Fuzzy” Squiggle Style
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Squiggle Basics

Napkin: The Napkin style looks like you are using a felt tip pen on
a paper napkin. The style is comprised of three Squiggle actions:

Slide - 10, 10
Wiggle - 65, 16
Thicken - 30, 60

Figure 3-5. The “"Napkin” Squiggle Style
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Shaky: The Shaky style looks like you need to switch to decaf
coffee. The style is comprised of two Squiggle actions:

Tilt - 10, 5
Wiggle - 45, 30

Figure 3-6. The “"Shaky” Squiggle Style
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Squiggle Basics

Sketch: The Sketch style looks like a wiggled line with small
inkblots at the ends of the lines. The style is comprised of three
Squiggle actions:

Slide - 10, 0
Thicken - 5, 50
Wiggle - 45, 17

Figure 3-7. The “Sketch” Squiggle Style
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Steady: The Steady style looks like an architect's steady hand. The
style is comprised of one Squiggle action:

Wiggle - 47, 18

Figure 3-8. The “"Steady” Squiggle Style

Wavy: The Wavy style looks like curving, bending lines. The style
is comprised of two Squiggle actions:

Tilt-5,5
Bend - 30, 30

_——

i
o 811
it

i

Figure 3-9. The “"Wavy” Squiggle Style
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Squiggle Actions

Squiggle Basics

A Squiggle style consists of a sequence of one or more of the
following actions:

Bend
Slide
Sputter
Thicken
Tilt
Wiggle

Each action is defined by two variables whose values range from 0
to 100. The higher the value, the more exaggerated the effect of
that action will be. (Refer to Tips and Tricks for Squiggle Actions for
some general action definition guidelines.)
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Bend

Bend can waver or curl like an unsteady hand. Your original line is
replaced by a series of lines that curve up (Rise) or down (Fall)
along the same path.

rise
BEND
C ©

—

fall

Figure 3-10. The “"Bend” Action

Figure 3-11. Typical Drawing After Applying the “"Bend”
Action
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Squiggle Basics

Slide

Slide looks like the stylized sketch where lines cross or don’t quite
meet. The ends of your original line are pulled back (Under) or
pushed out (Over).

over under
SLIDE E
G ©
Y
© o

Figure 3-12. The “Slide"” Action

AN @W
LL(EWE :“ ] W/__E ‘ :

Figure 3-13. Typical Drawing After Applying the “Slide”
Action
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Sputter

Sputter looks like a scratchy pen that is running out of ink or can’t
write across a waxy spot on a piece of paper. Your original line is
broken into a series of lines (Draw) and empty spaces (Miss).

draw miss
SPUTTER
< ©
<
G — — o

Figure 3-14. The “Sputter” Action

Figure 3-15. Typical Drawing After Applying the “Sputter”
Action
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Thicken

Thicken looks like pen work on absorbent paper where lines are
thicker as you start and stop. The ends of your original line are
more or less darker and thicker. Specify the maximum thickness
(Spread) and the range over which Thicken applies (Length).

length
spread H
T~ THICKEN
g )
L Iy

Figure 3-16. The “"Thicken” Action

Figure 3-17. Typical Drawing After Applying the “"Thicken”
Action
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Tilt
Tilt looks like a quick sketch done without a parallel rule. The ends

of your original line slide along the line itself and tilt perpendicularly
away from it.

along

away H
N TILT

Figure 3-19. Typical Drawing After Applying the “Tilt” Action
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Wiggle

Wiggle looks like a sketch done in a car as it bounces and sways.
Your original line is broken into a series of lines. The shared ends of
those new lines are then moved up or down perpendicular to the
original line. Specify the Wiggle maximum draw range for the new
lines (Breakup) and the maximum range of movement for the new
line ends (Bounce).

breakup

bounce H
—~ WIGGLE

Figure 3-21. Typical Drawing After Applying the “"Wiggle”
Action
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Tips and Tricks for Squiggle Actions

When you Squiggle a drawing, Squiggle 5 reads the list of actions
for the selected style. The first action is performed and the results
are passed along to the next action. In other words, the action
order is important!

Picture a long straight line. If you use Slide then Wiggle, the result
is a row of irregular lines longer overall than the original. If you use
Wiggle then Slide, the result is a row of irregular lines with
overlapping ends or ends that don't meet.

To see this for yourself, try changing the action order for the
“Napkin” style.

Select Style... from the Format menu.
Select the “"Napkin” style in the Name: drop-down menu.

1
2
3 Select the first action, Slide, in the action order list.
4 Click Move Down button.

5

Notice how the sample graphic reflects this change.

The best way to determine the action settings and action order that
give you the results you want is through trial and error. To
maximize trial and minimize error, here are some guidelines:

Bend: Set Rise or Fall to 0 for a scalloped effect. Set both greater
than 0 for wavy effects.

Apply other actions like Wiggle or Sputter before Bend. Because
Bend produces lots of little lines to make up the curves, subsequent
actions will seem to have little (if any) effect on each of those little
lines.

Slide: Set Under to 0 for an architectural drafting style where lines
always meet or cross at intersections. Set Over to 0 so that no lines
ever quite meet.

Tilt: Set Away to a high nhumber and Along to 0 when you want to
preserve the length of original lines but scatter them like straw.

Wiggle: Set Bounce to a high number and Breakup to a low
number when you want to crumple lines like accordion pleats.
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Viewing Your Drawing

Viewing Your Drawing

Layouts

Select Layouts... from the View menu to switch between layouts
defined in the drawing file. Highlight the layout you wish to use and
click OK.

You can also use the Layouts drop-down menu in the standard
toolbar.
Named Views

Select Named Views... from the View menu to switch between
named views defined in the drawing file. (You can also click on the
Named Views icon () in the standard toolbar.)

Highlight the named view you wish to use and click OK.

Zooming, Panning and Rotating

Select Zoom, Pan or Rotate from the View menu to view your
drawing from various distances, locations and/or angles. (You may
find it easier to use the Squiggle Toolbars to perform these
actions.)
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Layer

Select Layer... from the Format menu to manage drawing layers
and adjust layer properties.

Layer Froperties Manager B
Mame | On | Freeze | Lock | Color | Linetype | Lineweight | -
0 7] [+ = M Black Continuous 0.00 mm
Lay000 v [»] £ [E: Continuous  —— 0.00 mm
L0 v [»] ' MEFRed Continuous  —— 0.00 mm
Lavo02 v 4] £ Ovellow Continuous — ——— 0.00 mm
Lav003 v [»] ' [Green Continuous  —— 0.00 mm
Lasand 9 4] = [DCyan Continuous — —— 0.00 mim
LaY005 v [»] = MEBlue Continuous  —— 0.00 mm
LaY006 7 i = [EMagenta Continuous ~ —— 0.00 mm
Lay007 v [»] = M Black Continuous  —— 0.00 mm
Lav003 v [»] £ [s Continuous ~ —— (.00 mm
Lavo0g Q ] £ 09 Cantinuous  ——— 0.00 rm
Laymo v [»] £ W10 Continuous  —— 0.00 mm
Lavom v [»] £ On Continuous  —— 0.00 mm
Lavm 2 v [»] = W12 Continuous  —— 0.00 mm
Lav 3 v [»] £ W13 Continuous  —— 0.00 mm
Lavan4 v [»] = W14 Continuous  —— 0.00 mm
Law0ls W ] £ MWi5 Continuous  ——— 0.00 mm
LaYTE v [»] £ HWi6 Continuous  —— 0.00 mm
LAY ] iy =N W1 Conbirun ——— (100 ram i
Ok I Lancel Help

Figure 4-1. Layer Properties Manager Dialog

Click on a layer name to select it. To select or change display
properties for multiple layers, hold down the <Ctrl> or <Shift>
key and click. To select all layers, check the Select All box.

This dialog box gives you the following options:
On: Click on this column to show ( I:;:') or hide ("') a layer.

Freeze: Click on this column to freeze () or thaw (i73) a layer.
Squiggle 5 hides frozen layers and ignores the data on them
whenever it needs to recalculate the on-screen image. This can
help speed up screen redraws.

Lock: Click on this column to lock (ﬂ) or unlock (i'l) a layer.

Color: Click on the Color column to select a new color for a layer.

Viewing Your Drawing
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Viewing Your Drawing

Linetype: Click on the Linetype column to select a new linetype
for a layer.

Squiggle 5 only works with linetypes stored in the drawing. It
cannot add new linetypes.

Lineweight: Click on the Lineweight column to select a new
lineweight for a layer.

To edit the properties of a layer, left-click to bring up a dialog box,
or right-click to bring up a pop-up menu.

To edit the properties of multiple layers, hold down the <Shift>
key and left-click to bring up a dialog box, or right-click to bring up
a pop-up menu. This will apply your choice to all selected layers.

Lineweight

Select Lineweight... from the Format menu to set the default
lineweight and change how lineweights are displayed.

Lineweight Settings E

= = Uit
Lineweights | -

0.00 mm ’7 & Milimeters (mm) ¢ Inches (in)
0.05 mm
0.09 mm
— 013 mm
0.15 mm

0.18 mm Default:  0.25 mm
0.20 mm

0.30 mm -

Min

b Max

"Adiust Dizplay Scale

Ok I Eancell Help |

Figure 4-2, Lineweight Settings Dialog

To make such changes globally, use the Squiggle 5 program
options dialog.
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Outputting from Squiggle

Export Use the Export command to convert a Squiggle drawing to another
format. To preview the exported image and adjust the export
settings beforehand, use the Export Preview command.

Export Preview

The Export Preview command shows you beforehand what your
exported image will look like, and allows you to optimize the image
to maximize the quality while minimizing the size of the exported
file.

Format: Choose the desired format for the exported image -- BMP,
GIF, PNG, JPEG, TIFF, DWF or SVG.

Colors: If you know that your drawing contains fewer than 256
colors (or 216, in the case of the Web palette), you can reduce the
exported file size by selecting a subset of the chosen palette.

Dither: Dithering creates adjacent pixels of different colors to
simulate a new color. Dithering creates the appearance of more
colors and more detail in an image, but may also result in a larger
file.

If your drawing has lots of continuous-tone colors (gradients), it
may require dithering to prevent color banding and loss of detail in
the exported image. Drawings consisting mainly of solid colors
generally do not require dithering.

Scale: Click and drag on the Percent slider to reduce or enlarge
the exported image. To retain the aspect ratio (proportions) of the
original, leave the Constrain box checked.

Enlarging the exported image will result in a loss of resolution.

E Note
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Pan/Zoom: To position the desired viewing area in the preview
window, click the Pan button, then click and drag with the mouse
in the window.

To zoom in on the preview image, click the Zoom button, then click
repeatedly on the preview window. Or, to zoom in or out, use the
drop-down menu to select a zoom level.

Zooming in or out on the preview image does not affect the
exported results.

When you are satisfied with the preview, click the Export... button.
In the dialog that appears, type a name for the file (you can omit
the extension), select a destination and click Save.

Viewing Exported DWF and SVG Files: The Autodesk Drawing
Web Format (DWF) and the Scalable Vector Graphics Format (SVG)
are two popular standards for displaying and manipulating
vector-based graphics within a web browser. Squiggle 5 can export
drawing files in either format.

Doing so allows you to share squiggled drawings with colleagues
who don’t use CAD software; they need only a web browser and the
necessary third-party software:

e For viewing exported DWF files: a stand-alone viewer such as
Volo™ View Express or a browser plug-in such as the WHIP!
ActiveX Control will suffice. Both are freely available from
Autodesk.

e For viewing exported SVG files, Adobe Systems offers an SVG
Viewer Plug-In on its web site.

The Squiggle 5 CD-ROM includes installer programs for both the
WHIP! ActiveX control and the Adobe SVG Viewer Plug-In.
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Save As

Use the Save As command to save a Squiggle document (DXF,
DWG or PLT) as either a DWG or DXF file.

Save As allows you convert files to a format recognized by older
CAD programs (for example, AutoCAD Release 2.5 and later),
should you need to do so.

The default file format for the Save As command is AutoCAD 2000/
2002 DWG. To change this, use the program options dialog.

Copy to Clipboard

The Edit menu has a single command: Copy to Clipboard. From the
Clipboard, your Squiggled drawing can be pasted into most
Windows applications.

Plot Use the Plot command to adjust plotting options and plot your
drawing. (To preview the plotted image before sending it to the
plotter, use the Plot Preview command.)

Plot Settings:

e Paper Size/Units: Select a paper size for your output. The
available choices may vary from one plotter model to another.

e Drawing orientation: Select Portrait or Landscape orientation
for your output. To plot the drawing upside-down, check the box.

¢ Plot Area: Choose Extents to scale the plotted image to fit
within the page margins. Choose Display to plot what is
currently displayed on the screen.

e Options: To plot the drawing in black and white, check the box.
Click OK to send your drawing to the plotter.
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Plot Preview

The Plot Preview command shows you beforehand what your
plotted image will look like, and gives you the following output
options:

Plot Area: Choose Extents to scale the plotted image to fit within
the page margins. Choose Display to plot what is currently
displayed on the screen.

If both the Squiggle program window and the drawing window are
maximized, both of these settings produce the same output.

Drawing orientation: Select Portrait or Landscape orientation for
your output. To plot the drawing upside-down, check the box.

Options: To plot the drawing in black and white, check the box. For
multiple copies, enter a new value in the box labeled Number of
copies.

Click the Plot button to send your drawing to the plotter.

Outputting from Squiggle
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Page Setup

Use the Page Setup command to select a plot device and set other
default output options.

Plat Device | Flot Settings |
— Plotter configuration
Mame: j
Flotter: Drefault PostScript Printer
where: FILE:
Drescription:
— Inzsight plot style table (pen assighments) Elatstamp—————
M ame: INone 'l Bt | Hew... I ’7 J= | SEthings.. |
—'what to plot Elattofile
& Curent B R =
L File mame; I
Mumber of copies: |1 3: Location: I j
QK I Cancel | Spply | Help |

Figure 5-1. Page Setup Dialog - Plot Device Options

Plot Device Options:

Plotter configuration: This area of the dialog shows you the
currently-selected output device, the output destination (printer
port or file) and a description of the device, if one was entered
when the device was installed on your system.

Use the drop-down menu to select a different output device.

Insight Plot Style Table: Insight Plot Style Tables let you
override the pen properties defined in your drawing file before
sending it to a plotter. For more about plot style tables, refer to
Insight Plot Style Tables in Chapter 6, Customizing Squiggle.

What to plot: For multiple copies, enter a new value in the box
labeled Number of copies.

Click OK to save your settings.
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Customizing Squiggle

Custom Styles

If a preset Squiggle style doesn’t give you the results you want,
you can create your own. (Refer to Tips and Tricks for Squiggle
Styles for some general style creation guidelines.)

To create a custom Squiggle style:

1 Select Style... from the Format menu. Or, select Squiggle...
from the Tools menu and left-click anywhere in the Style

column.
Select Style
—Sampl
Impart I Save | Delete I
Action Order:
Maove Up |
Mave Down |
— Update preview image————————————————————
[™ Force manual refresh Refresh

Actiong:
1 Bend I Slide I Sputter —— I Thicken — T Tik T Wwiggle
Fise F&ll Hier Wnder [rayy s Length Spread Alorg Away Ereak up Bounce
] ] ] ] ] ]
lfjnj 100 alLejij lfjnj lfjnj alLejij
0 1] 0 0 1] 0 0 1] 0 0 1] 0
Ok I Lancel Help Adyaticedl |

Figure 6-1. Select Style Dialog

Customizing Squiggle 6-1



Squiggle 5 User’s Manual

E Note

6-2

Select an action by checking the box next to its name.

To adjust the parameters for that action, drag the sliders using
the mouse. Notice how the sample image is redrawn to give you
an idea of the effect of the action.

To force the preview image to be refreshed manually, check the
Force manual refresh box. Subsequent changes to the action
order or action settings are not reflected in the preview image
until you click the Refresh button.

Repeat Steps 2 and 3, as desired.

5 To change the order in which Squiggle 5 performs the actions,
select one in the Action Order: list and click the Move Up or
Move Down button.

When you are finished defining your custom style, click Save.

In the dialog box that appears, type a name for the style
definition file (you can omit the extension), select a destination
and click Save.

Tips and Tricks for Squiggle Styles

Squiggle styles always produce random effects. However, certain
kinds of input data will influence the way these styles look on your
data.

Line Lengths: The longer the lines in your input data, the less
effect you'll see after squiggling. The opposite is also true. A style
that has little or no apparent effect on longer lines will appear
“busy” on very short ones.

Line Direction: All lines have a start and a finish. Squiggle 5
applies a style starting at one end of each line and continues to the
end. Some Squiggle styles will look different on two parallel lines
that were drawn in opposing directions.

Data Complexity: If your drawing contains lots of lines that are
close together, the effect may look more jumbled than it would on
simpler, more sparse data.

Realism: Finely-drafted and very accurate objects may quickly
become unrecognizable with the more exuberant styles. To retain
this quality, consider creating a custom style consisting of fewer
and/or more subtle actions.

Customizing Squiggle
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Importing Squiggle Styles

You can also import styles created by other Squiggle 5 users.
Squiggle 5 saves style definitions as small files with an “.sqg”
extension.

To import a Squiggle style:

1 Select Style... from the Format menu. Or, select Squiggle...
from the Tools menu and left-click anywhere in the Style
column.

Click the Import button.

Locate the style definition file on your local machine or network
using the dialog.

4 Highlight the file and click Open. The imported style will be
available to you the next time you Squiggle.

Pen Templates

Pen templates are a simple yet powerful way to establish drafting
or presentation standards.

A pen template defines a standard set of pens in terms of RGB color
value, lineweight and Squiggle style. Once you create a pen
template, you can apply it to each new file in a project or make it
available to anyone who is working on similar documents.

You can establish pen templates as office standards for different
drawing sizes or design phases, brochures or other publications.

To create, edit or import pen templates, select Pen Templates...
from the Format menu. Squiggle 5 provides a default "AutoCAD”
pen template. You can also import pen templates created by
others, or create your own.

To create a new pen template:
1 Click New...

2 Enter your name (and/or company name) and a short
description of your pen template.

3 Click OK.
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4 Type a name for the pen template file and click Save.

Select Pen Template E

Template | Author | Diescription | File

AutaCaD Insight Develo...  AutaCAD Pen Settings RS

siteplans Iharriz Site Flans [T
Import... |
Todify... |
Bemove |

«| | »

aK | LCancel I Help |

Figure 6-2. Select Pen Template Dialog

5 Select the pen template you just created and click Modify...

FPen | Color | Lineweight | Style | -
1 |1 Default Mone
2 Oz Default Mone
3 ] Default Mone
4 o4 Default Mone
5 B Default Mone
g (5] Default Mone
7 N Default Mone
g ma Default Mone
| (] Default Mone
10 W10 Default Mone
1 o Default Mone
12 |2 Default Mone
13 W13 D efault Mone A
0k I LCancel | Help |

Figure 6-3. Pen Template Editor Dialog
6 Click on a pen number to select it. To select multiple pens, hold

down the <Ctrl> or <Shift> key and click. To select all pens,
check the Select All box.
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7 Click on the Color column to select a new color for a pen.

Select Palette Color E

— Gray Shadez
AENEEEEEEEEEEEEEEEE
HEEENEEEEEEEEEEN

—Standard Colors—————————————— Selected Color—————————
(WS T {. —
|

— Full Color Palette

ANEEEEEEEEEEEEEEEn
l.llll.llll.llll==

HEEN M NNeenEn
||||||||||||||||.=

ENEENEEEEEEEEEEE.

AN EEEEENEEEEE
ANEEEEEEEEEEEEEEEEEEEEEE
ANEEEEEEEEEEEEEEEEEEEEEE

~RGE Yalue

Green: IU 3: Blue: IU 3:

Ok I Qancell Help |

Figure 6-4. Pen Template Editor - RGB Color Picker Dialog

8 Click on the Lineweight column to select a new lineweight for a
pen.

9 Click on the Style column to select a Squiggle style for a pen.

To edit the properties of a pen, left-click to bring up a dialog box, or

right-click to bring up a pop-up menu.

To edit the properties of multiple pens, hold down the <Shift> key
and left-click to bring up a dialog box, or right-click to bring up a
pop-up menu. This will apply your choice to all selected pens.

When you are finished, click OK to save the changes to your pen
template.

To make the pen template you just created active, select it in the
list and click OK.
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Insight Plot Style Tables

Insight Plot Style Tables let you override the pen properties defined
in your drawing file before sending it to a plotter. For example, you
can create an Insight Plot Style Table that uses custom lineweights
not defined in the drawing file. Doing so does not alter the original
drawing file in any way.

Note Overriding pen lineweights can affect the results of certain actions.
For example, the “Fuzzy” and “"Sketch” styles use the Thicken
action, which in turn changes the lineweight of a squiggled line.

To create an Insight Plot Style Table:
1 Click New... in the Page Setup dialog to display the Plot Style

Table Editor.

Flat styles | [~ Propertie
Cola [

— Colar

IUse object color - l
Caolar 1

— Lineweight

IUse object lineweight VI
L L Edit... |

LCancel | Help |

Figure 6-5. Plot Style Table Editor Dialog

Select a pen in the list on the left.

To substitute a different pen color, select one using the Color
drop-down menu. (Select Custom Color to specify an RGB
value.)

4 To substitute a different lineweight, select "Custom Lineweight”
using the Lineweight drop-down menu. Click Edit... and enter
the desired lineweight for that pen.

5 Repeat Steps 2 through 4, as desired. When you are finished,
click OK.
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6 In the dialog that appears, type a name for the plot style file
(you can omit the extension), select a destination and click
Save.

To use the new plot style table, select it using the drop-down
menu. To make further changes to it, click the Edit... button.
Entity Types

Select Entity Types... from the Format menu to enable or disable
Squiggling of all entities of a given type in the current drawing. (To
make such changes globally, use the Squiggle 5 program options
dialog.)

Select Entity Types E3

— Supported Entity Type:

T o turn ondoff the Squiggle feature for
a specific entity type, check or

v CIRCLE uncheck the appropriate box for that
particular type. Click on the OF button

v ELLIPSE to accept these settings.

IV ARC

¥ POLYLINE

IV LwPOLYLINE
[V BLOCK/ %REF

Ok I Qancell Help |

Figure 6-6. Select Entity Types Dialog

By default, Squiggle 5 acts on all entity types in a drawing. To
exclude all entities of a given type from Squiggling, uncheck the
box for that entity type.

Click OK to confirm your selections.
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Options

Select Options... from the Tools menu to configure global Squiggle
5 program options. These options will be saved and used the next

time you use Squiggle.

General | Dizplay I Squiggle I Support Files I

—File Save —File Open

Save ast

[ButoCAD 2000/2002 Drawing (dwa) 7] [+ Qi

V' Save a thumbnail preview image
— Language — Option

Erglish =l

¥ Zoom Estents on Open

o]

Cancel

Apply

Figure 6-7. General Options Dialog

General: This dialog provides the following options:

¢ File Save: Select a default file format for the Save As...
command. (You can still select a different format each time you
save a drawing.) To save a thumbnail preview image with the
drawing, check the box so labeled.

¢ File Open: Specify how many recently-opened files you want to
appear in the File menu. The default is 4.

e Options: If you want to zoom to the drawing extents when you
open it, check the box. Similarly specify whether or not you want
Squiggle 5 to display the startup dialog when you launch the

program.
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@ Note

Customizing Squiggle

Dptions E

Units—————
|7 & Millimeters [mm)

General Display | Squigglel Support FiIesI

Line Color

™ Maonochrome

Dizplay Linetypes
' 0n
O

7 Inches [in]
— Lineweight

Lineweights - ¥ Display Linewsight
ggg zz Default:  0.25 mm
0.09 mim . .
013 mm Adjust Dizplay Scale
0.15 mm Win e
0.18 mm - i —

o]

Cancel | Lol Help

Figure 6-8. Display Options Dialog

Display: This dialog provides the following display-related options:

Background: Choose the desired background color (white or
black).

Line Color: Check the Monochrome box to suppress display of
line colors.

Display Linetypes: To turn the display of linetypes on or off,
click the appropriate radio button.

Units: To specify lineweights in millimeters or inches, click the
appropriate radio button.

Lineweight: Use these options to change the default
lineweights or adjust the display scale to affect how lineweights
are displayed.

The “"Adjust Display Scale” setting has no affect on printed output.
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General I Display ~ Squiggle | Support Files I
—Method————— Pen Template
JautaCaD =l
—a&rc Objects - Segment Length [in angle degrees]—— Squiggle Entity Types
| 15¢ [V LINE [V POLYLINE
o

1 45° v CIRCLE ¥ LwPOLYLINE

i~ Circle Objects - Segment Length [in angle degrees]— W ELLIPSE ¥ BLOCK/=REF
| - I ARC
1 45°

QK I Cancel | Spply | Help

Figure 6-9. Squiggle Options Dialog

Squiggle: Use this dialog to control the behavior of the Squiggle
function. It provides the following options:

¢ Method: Choose By Pens if you want to apply Squiggle styles to
all lines drawn with a given pen (regardless of the layer on which
they appear).

For greater control over the results when working with
multi-layered drawings, choose By Layers. Unlike squiggling by
pens, squiggling by layers allows you to contrast multiple layers
that use the same pen type.

¢ Pen Template: Select a pen template to use as a basis for
identifying pens in the Squiggle dialog.

¢ Arc Objects - Segment Length: Use this slider to increase or
decrease the effect of squiggling on arc objects. A small value
produces a more obvious result than a larger one.

For example, with the default setting of 15 degrees, Squiggle 5
treats a semicircle as 12 curved line segments. The maximum
value (45 degrees) causes Squiggle to treat that same semicircle
as four curved line segments, resulting in a more subtle effect.

Customizing Squiggle
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¢ Circle Objects - Segment Length: Use this slider to increase
or decrease the effect of squiggling on circle objects. A small
value produces a more obvious result than a larger one.

For example, with the default setting of 30 degrees, Squiggle 5
treats a circle as 12 curved line segments. The maximum value
(45 degrees) causes Squiggle to treat that same circle as eight
curved line segments, resulting in a more subtle effect.

e Squiggle Entity Types: By default, Squiggle 5 acts on all
supported entity types in a drawing. To exclude all entities of a
given type from Squiggling, uncheck the box for that entity type.

Dptions E
Generall Displa_l,ll Squiggle  Support Files |

Specify the locations of your suppart files [fonts, linetypes, hatch patterns, ete...]

bdd.. |
Bemove |
Move Up |
Move Down |

QK I Cancel | Lol | Help

Figure 6-10. Support Files Options Dialog

Support Files: If necessary, indicate the location(s) of the support
files (fonts, linetypes, hatch patterns and such) associated with
your CAD program. To change the order in which Squiggle 5
searches these locations for the support files it needs, use the
Move Up and Move Down buttons.

Click OK to save your option settings.
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Common
Squiggle 5
Issues

Troubleshooting

Troubleshooting

We have tried to make using Squiggle 5 as easy and trouble-free as
possible.

If you do run into problems that you cannot resolve on your own,
contact the Insight Development Technical Support Group via
e-mail at support@insightdev.com, or call +925.244.2000.

Here are some common issues that you may encounter with
Squiggle 5, along with their suggested corrective action(s).

IMAGE Entities In A Drawing Are Not Visible

Squiggle 5 does not currently support the IMAGE entity. Although
this entity will still be part of the drawing, it will not be visible. If
you need this capability, save your squiggled drawing back to a
DWG or DXF file and use your original CAD application to work on
the drawing.

Text and Hatch Patterns Do Not Squiggle

Squiggle 5 does not support modifying all AutoCAD entities. When
using a drawing in Squiggle that contains unsupported items you
wish to modify (such as text or hatch patterns), the best solution is
to generate a plot file and open the HPGL or HPGL/2 file in
Squiggle. Or, use the “explode” feature of AutoCAD to convert
unsupported entities into lines which can then be modified by

Squiggle.

Squiggling Produces Very Large Files

It is normal behavior for Squiggle 5 to produce a file that is larger
than the input one. In extreme cases, however, this may overflow
your plotter or printer. If this occurs, try again with a less complex
Squiggle style.
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Squiggle 5 Menus,
Toolbars and Keyboard
Shortcuts

This Appendix provides an overview of the Squiggle 5 menus,
toolbars and keyboard shortcuts.

Squiggle Menus Squiggle 5 commands and functions are grouped into seven
menus:

File Edit “iew Format Tools ‘Window Help

You can access a subset of the commands in these menus by
right-clicking on a Squiggle drawing window.

Squiggle. .. F5
Fesguiggle F&
Unsguiggle F7.

Zaom
Fan

Save As...
Expork...
Export Preview...

Plot... Chrl+P

You can use these menus to interact with Squiggle 5, or if you
prefer, you can use the toolbars and/or keyboard shortcuts.

Squiggle 5 Menus, Toolbars and Keyboard Shortcuts A-1
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A-2

Squiggle 5 Menu Command Summary

- Keyboard
Menu Description Shortcut
File Manage basic Squiggle processes.
Open... Open a drawing file. <Ctri>+0
Close Close the current
drawing file.
Close All Close all open files.
Save As... Save current drawing
as a DWG or DXF file.
Export... Convert current
drawing to another
format.
Export Adjust export settings,
Preview... preview image and
convert current
drawing to another
format.
Plot... Adjust plotting options | <Ctri>+P

and plot a drawing.

Squiggle 5 Menus, Toolbars and Keyboard Shortcuts
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Squiggle 5 Menu Command Summary (continued)

i Keyboard
Menu Description Shortcut
Plot Adjust plotting
Preview... options, preview
output and plot a
drawing.
Page Setup... | Select a default output
device, plot style table
and other output
options.
Drawing View information
Properties... about the current
drawing file.
(recently- Quickly access
opened files) | recently-opened files.
Exit Exit Squiggle 5.
Edit Copy to Copy the current <Ctri>+C
Clipboard drawing to the
Windows clipboard.
Squiggle 5 Menus, Toolbars and Keyboard Shortcuts A-3
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Squiggle 5 Menu Command Summary (continued)

Keyboard

Menu Description Shortcut

View View your drawing from various
distances, locations and/or angles;
show/hide toolbars.

Redraw Refresh the display.

Regen Regenerate the
drawing and refresh
the current view.

Zoom Change the apparent
size of objects in the
drawing window.

Pan Change the viewable
area of the drawing in
the window.

Rotate Rotate the drawing.

Layouts... View or switch

between layouts
defined in the drawing

file.

Named View or switch

Views... between named views
defined in the drawing
file.

Toolbar Show or hide the

Standard, Pan, Zoom
and Rotate toolbars.

Status Bar Show or hide the
Status bar.
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Squiggle 5 User’s Manual

Squiggle 5 Menu Command Summary (continued)

I Keyboard
Menu Description Shortcut
Format Manage styles, pen templates, layers
and other drawing elements.
Style... Import, create, edit or
delete Squiggle styles.
Pen Import, create, edit or
Templates... | delete pen templates.
Entity Enable or disable the
Types... Squiggle function for
specific entity types.
Layer... View and change
drawing layer
properties.
Lineweight... | Set the default
lineweight, lineweight
display options and
lineweight units.
Tools Set default Squiggle 5 options;
manage/apply Squiggle styles.
Squiggle... Squiggle a drawing F5
file.
Resquiggle Repeat last Squiggle F6
operation.
Unsquiggle Restore a drawing to F7
its “pre-squiggled”
state.
Options... Configure Squiggle 5 F10
default settings.
Squiggle 5 Menus, Toolbars and Keyboard Shortcuts A-5
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Squiggle 5 Menu Command Summary (continued)

I Keyboard
Menu Description Shortcut
Window Arrange open drawing windows within
the Squiggle program window.
Cascade Arrange windows in an
overlapping fashion.
Tile Arrange windows top
Horizontally to bottom.
Tile Vertically | Arrange windows side
by side.
(list of open Switch from one open
files) drawing to another.
Help Information and resources for
Squiggle 5 users.
Squiggle Access Squiggle 5 F1
Help... online help.
What's New View brief descriptions
of new features in
Squiggle 5.
Getting Helpful information
Started... for users new to
Squiggle 5.
Support Squiggle 5 technical
support resources.
Insight on Go to the Insight
the Web Development web site.
About View information
Squiggle... about your version of

Squiggle.

Squiggle 5 Menus, Toolbars and Keyboard Shortcuts
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Squiggle
Toolbars

Squiggle 5 Menus, Toolbars and Keyboard Shortcuts

If you prefer, you can use Squiggle 5’s numerous toolbars to get
around the program. Select Toolbar-> from the View menu to
show or hide the individual toolbars.

Eile Edit View Fomat Tools Window Help
ﬁn§|m|@a@§i\|%”ﬁlﬂd815pace jo‘?
Q& |AA @664k &@ tmalefn ] |efstetetet

Figure A-1. Squiggle Toolbars

Standard
Squiggle pan drawing properties
sav‘e as zoom‘extents ‘ named views ‘
Jﬁn§|@|@@@§3|%||MadelSpace ) ?|
op‘en zoom ‘ window /ay‘ers ht‘elp
plot zoom previous layouts
Figure A-2. Standard Toolbar
Zoom
window extents in out  previous
Figure A-3. Zoom Toolbar
Pan
pan left right up down
Figure A-4. Pan Toolbar
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Keyboard
Shortcuts

A-8

Rotate
right forward clockwise
& & &b & @|rglelss o] |
left backward counter-clockwise

Figure A-5. Rotate Toolbar

Here are some additional keyboard shortcuts you may want to keep
in mind, in addition to those listed at the beginning of this section:

e To switch between open document windows, press
<Ctrl>+<Tab>. Or, use <Alt>-W followed by the window
number shown in the Window menu (for example, 1 for the first
drawing you opened).

e To switch between “layers” in tabbed dialog windows (such as
the Tools -> Options dialog), press <CtrI>+<Tab>.

e All Squiggle 5 commands have been implemented as “Alt” key
sequences; for example:

e Drawing Properties = <AlIt>-F-I

e Show/Hide Toolbars = <AIt>-V-T

e Squiggle = <AlIt>-T-S

e Unsquiggle = <AIt>-T-U

In each sequence, the first keystroke after the <Alt> key
represents the menu; the second represents the command or
sub-menu. For each menu and command name, the

corresponding <AIt> keystroke is underlined (for example,
“Format”).

Squiggle 5 Menus, Toolbars and Keyboard Shortcuts
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A
AutoCAD 5-3, 6-3, 7-1

D

dither 5-1

Drawing Exchange Format. see DXF
Drawing Web Format. see DWF
DWF 1-3, 5-2

DXF 5-3

Export Preview command 5-1

I
Insight Plot Styles 1-4, 5-5, 6-6, A-3

K
keyboard shortcuts A-2, A-8

L

layers
squiggling by 6-10

named views 4-1
new features 1-3

P

pen templates 6-3, 6-10
pens

squiggling by 6-10
plotting 5-4
PNG 1-3

Index

Index

Portable Network Graphics. see PNG
printing 5-4
program options 6-8

S
Scalable Vector Graphics. see SVG
squiggle
by layers 1-3, 6-10
by pens 1-3, 6-10
styles
custom 6-1

SVG 1-3, 5-1, 5-2

T

toolbars A-7
troubleshooting 7-1

U

uninstalling 2-8
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